Ajuda - Integração SmartThings

Olá pessoal. Preciso de ajuda para integrar HA com SmartThings. Já está liberado com acesso externo e o token já foi liberado. Porém, ao tentar adicionar integração fica nessa tela direto. Já reiniciei, e continua a mesma coisa.



1 Like

Bom dia,

Estou com um problema parecido, já apaguei e criei novamente o token, mas o erro persiste:

image

Se alguém já passou por isso, agradeço a ajuda!!

Fala pessoal, tudo bem?

Desde ontem (19/11/2021) a minha integração com o hub smartthing parou, do nada, tentei fazer o básico e não voltou, pesquisei o erro em alguns fóruns e só resolveram fazendo a integração de novo, tô com medo de ir pra esse procedimento porque grande parte dos meus dispositivos estão nele e vão dar um puta trabalho ajustar tudo novamente :frowning: Alguém mais passando por isso? Segue o erro:

Logger: homeassistant.config_entries
Source: components/smartthings/init.py:121
First occurred: 08:47:38 (1 occurrences)
Last logged: 08:47:38

Error setting up entry Casa for smartthings
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/config_entries.py”, line 304, in async_setup
result = await component.async_setup_entry(hass, self) # type: ignore
File “/usr/src/homeassistant/homeassistant/components/smartthings/init.py”, line 121, in async_setup_entry
token = await api.generate_tokens(
File “/usr/local/lib/python3.9/site-packages/pysmartthings/smartthings.py”, line 209, in generate_tokens
result = await self._service.generate_tokens(
File “/usr/local/lib/python3.9/site-packages/pysmartthings/api.py”, line 424, in generate_tokens
raise APIInvalidGrant(data.get(“error_description”))
pysmartthings.errors.APIInvalidGrant: Invalid refresh token: b1ceba72-383f-4fda-864f-6d3f3f0e0689

Desde já agradeço

Eu novamente com outro problema de integração com o Smartthing, mesmo que não apareça ninguém pra ajudar é bom deixar registrado que essa integração não é recomendada, por toda hora da um erro diferente, segue o atual:

image

Abs,

Boa noite, passando pra dizer que resolvi o meu caso, não sei se funcionará para todos, mas como não consegui ajuda, pode ser que alguém passe pelo mesmo, segue:

1- Subi uma VM e recuperei o backup do meu RaspBerry (muito importante ter backups diários)
2- Acessei a interface pelo NabuCasa
3- Iniciei a configuração de integração e apaguei todos os tokens existentes no Smartthing, criei um novo
4- Coloquei o token novo e tudo funcionou
5- Fiz um backup
6- Fiz restore no RaspBerry e voltou a funcionar

Abs,