Tomada zigbee não reconhecida no z2mqtt

Pessoal,
Comprei umas tomadas zigbee e elas não foram integradas via z2mqtt. Comprei uma unidade e após todos os testes, funcionando perfeitamente, comprei mais 5 unidades. Pra minha surpresa essas não foram reconhecidas. Alguma alternativa, ou terei que devolvê-las!?


A que foi reconhecida apareceu modelo diferente:

As embalagens são iguais, mesmo vendedor mas pelo jeito internamente não são a mesma coisa.

Tive o mesmo problema, para resolver só seguir isso que está na DOC: Support new devices | Zigbee2MQTT

Essa atualização já foi feita aqui TS011F Smart Plug by RSGSP · Pull Request #4014 · Koenkk/zigbee-herdsman-converters · GitHub, mas ainda não geraram uma versão no Zigbee2MQTT.

Pelo que vi, é o mesma tomada que comprei e tive o mesmo problema, segue o arquivo:

const fz = require('zigbee-herdsman-converters/converters/fromZigbee');
const tz = require('zigbee-herdsman-converters/converters/toZigbee');
const exposes = require('zigbee-herdsman-converters/lib/exposes');
const reporting = require('zigbee-herdsman-converters/lib/reporting');
const extend = require('zigbee-herdsman-converters/lib/extend');
const e = exposes.presets;
const ea = exposes.access;

const definition = {
    zigbeeModel: ['TS011F'],
    model: 'TS011F',
    vendor: 'TuYa',
    description: 'Smart plug (with power monitoring)',
    fromZigbee: [fz.on_off, fz.electrical_measurement, fz.metering, fz.ignore_basic_report, fz.tuya_switch_power_outage_memory,
        fz.ts011f_plug_indicator_mode, fz.ts011f_plug_child_mode],
    toZigbee: [tz.on_off, tz.tuya_switch_power_outage_memory, tz.ts011f_plug_indicator_mode, tz.ts011f_plug_child_mode],
    configure: async (device, coordinatorEndpoint, logger) => {
        const endpoint = device.getEndpoint(1);
        await reporting.bind(endpoint, coordinatorEndpoint, ['genOnOff', 'haElectricalMeasurement', 'seMetering']);
        await reporting.rmsVoltage(endpoint, {change: 5});
        await reporting.rmsCurrent(endpoint, {change: 50});
        await reporting.activePower(endpoint, {change: 10});
        await reporting.currentSummDelivered(endpoint);
        endpoint.saveClusterAttributeKeyValue('haElectricalMeasurement', {acCurrentDivisor: 1000, acCurrentMultiplier: 1});
        endpoint.saveClusterAttributeKeyValue('seMetering', {divisor: 100, multiplier: 1});
        device.save();
    },
    exposes: [e.switch(), e.power(), e.current(), e.voltage().withAccess(ea.STATE),
        e.energy(), exposes.enum('power_outage_memory', ea.STATE_SET, ['on', 'off', 'restore'])
            .withDescription('Recover state after power outage'),
        exposes.enum('indicator_mode', ea.ALL, ['off', 'off/on', 'on/off', 'on'])
            .withDescription('Plug LED indicator mode'), e.child_lock()],
};

module.exports = definition;

@luizhgois
Salvo esse codigo dentro da pasta config e com extensão .js e incluo no configuration.yaml o “advanced” que tá na documentação… é isso?? Sou leigo nisso!!!

Isso mesmo.
O meu conforme coloquei o arquivo na pasta do zigbee2mqtt, já reconheceu sozinho. Depois de adicionar, acho que é necessários dar um restart.

1 Like

Amigo,
Não consegui aqui… pode me ajudar? o meu ficou assim



Ontem saiu a atualização do Zigbee2MQTT, faz a atualização dele que vai resolver. Com a atualização, não precisa adicionar o arquivo JS

1 Like

A atualização 1.25 não rodou pra mim! Atualizei até o firmware do dongle sonoff e nada… não sei por qual motivo!!! Quando fiz restore no backup funcionou tudo normal na versão 1.24. Dá erro de conexão!

Instalei a versão edge e as tomadas funcionaram perfeitamente!