Sonoff Dongle E + Zigbee 2mqtt - configuração

Pessoal sou novo no HA . Estou tentando instalar o dispositivo acima mas não consigo. Ja vi varios videos, fiz todo passo a passo e nada. Alguem saberia me dar uma luz do que pode estar errado?

Aqui aparece uns erros no Log:

[20:25:42] INFO: Preparing to start…
[20:25:42] INFO: Socat not enabled
[20:25:43] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:info 2024-03-21 20:25:44: Logging to console and directory: ‘/config/zigbee2mqtt/log/2024-03-21.20-25-44’ filename: log.txt
Zigbee2MQTT:info 2024-03-21 20:25:44: Starting Zigbee2MQTT version 1.36.0 (commit #unknown)
Zigbee2MQTT:info 2024-03-21 20:25:44: Starting zigbee-herdsman (0.35.1)
Zigbee2MQTT:error 2024-03-21 20:25:44: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2024-03-21 20:25:44: Failed to start zigbee
Zigbee2MQTT:error 2024-03-21 20:25:44: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2024-03-21 20:25:44: Exiting…
Zigbee2MQTT:error 2024-03-21 20:25:44: Error: spawn udevadm ENOENT
at Process.ChildProcess._handle.onexit (node:internal/child_process:284:19)
at onErrorNT (node:internal/child_process:477:16)
at processTicksAndRejections (node:internal/process/task_queues:82:21)

Posta seu arquivo de configuração

Desculpa a ignorancia. Arquivo de configuracao é o que esta em opções?

Seria isso?

Socat

enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: “-d -d”
log: false

Mqtt

server: mqtt://core-mosquitto:1883
user: mqttuser
Password: xxxx

Serial

Port: >-
/dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20231216164746-if00
adapter: ezsp

O zha está desabilitado?

Sim, quando conectado ele recomhece o dongle
mas eu desabilitei la manualmente. Mesmo assim, nada.

Apaga o arquivo config/zigbee2mqtt/coordinator_backup.json e edita o config/zigbee2mqtt/configuration.yaml igual esta abaixo,
mudando os dados do mqtt e a porta usb, depois inicia o z2m e vê se resolve.

frontend:
  port: 8099
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://core-mosquitto:1883'
  user: mqttuser
  password: pwd
serial:
  port: /dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20231216164746-if00
  adapter: ezsp
advanced:
  pan_id: GENERATE
  network_key: GENERATE
  ext_pan_id: GENERATE
  channel: 25
1 Like

Cara, não achei o primeiro arquivo que você disse para apagar mas editei o .yaml conforme sua orientação e funcionou !!

Nossa! Tinha assistido vários videos e ficado horas tentando aqui e nada. Agora sim!
Muito obrigado mesmo irmão !