Sirene - Alarme Ekasa (Nas - ab02b2 - V2 20210930) Aparece como: Não suportado no Zigbee2mqtt

Boa noite a todos.
Eu tenho 2 sirenes da ekasa zigbee (modelo Neo NAS-AB02B2), pareio elas no zigbee2mqtt porém só aparece a qualidade do link e como não suportado.

No link acima diz que é compatível, porém elas aparecem como [TS0601] tanto na pagina inicial e no console, e tenho outras que comprei no aliexpress, aparecem como NEO, [NAS-AB02B2] na pagina inicial e no console mostra modelo TS0601.
Consigo parear elas no hub da tuya através do smartlife normalmente, porem queria pelo zigbee2mqtt pois minha rede zigbee é toda nele.
Me salvem hehe

Você pode tentar mapear o dispositivo seguindo a documentação do z2m.

Eu fiquei um pouco confuso com a documentação e sou meio leigo para isso.
Mas eu tentei fazer isso (espero que da forma correta), na pasta do Z2m, criei o arquivo ext_converter.js e joguei o código nele. Em configuration.yaml da pasta do Z2m, inclui

  • advanced:
  • log_level: debug
  • external_converters:
    • external_converter.js

Porém sem sucesso. Ou talvez esteja fazendo da forma errada.

@D4n0n3 conseguiu alvo novo? Estou com o mesmo problema, no Z2M aparece só TS0601 mas sem suporte sem entidades.

Nada novo infelizmente, se descobrir por favor volte aqui e nos de uma luz kk. Comentaram sobre mapear o dispositivo, porém não sei ao certo como faze-lo. Já pesquisei, tanto no BR e site gringos, porém nada muito claro ou assertivo.
Obs: tenho 4 sirenes da neo, mesmo modelo funcionando perfeitamente no z2m.

Poderia nos dar um help por favor?

Encontrei isso, porém sem sucesso, talvez esteja fazendo algo errado.

Atualização: Depois de muita luta e pesquisas, consegui com a ajuda do Felipe.
Em resumo, quando encontrei o código certo, estava puxando ele, com erros de endentação(algo bobo rs).
Solução: copiei o código do Felipe e adicionei no ext_converters e puxei esse arquivo no final do configuration.yaml do z2m.
@medeiroshb

Se precisarem de ajuda, pode me chamarem aqui. E deem o feedback haha

Funcionou de primeira com esse código valeu cara!

Só uma coisa, o meu é a versão com sensor de temperatura e umidade (mesmo ID: _TZE204_q76rtoa9) e notei que no código dele não tem esses exposes, o seu pegou esses sensores? sabe como faz pra adicionar? @D4n0n3

1 Like

A minha, eu abri ela e confirmei que era a NAS-AB02b2, mas a minha ela não possui essas funcionalidades. Responde o Felipe lá no Github, o cara é muito gente boa e vai te ajudar melhor.
Eu acho que a que possui temp e humidity é a NAS-AB02B0
Tem a documentação do z2m se for

Coloquei o modelo NAS-AB02B0 no .js mas não funcionou, vou dar um toque no Felipe, valeu

1 Like

Conseguiu? Nos conte aqui, para poder ajudar mais pessoas que estiverem procurando.