HD cheio HomeAssistant

Bom dia pessoal, tenho um HomeAssistant OS rodando em um Intel NUC.
Por muito tempo ele não me deu problema, ele ficava sempre com cerca de 10gb de armazenamento ocupado dos 128gb que ele tem.
Nisso fiquei uns 2 meses sem mexer nele, só atualizando os add-ons e o sistema, até que certo dia percebi que ele estava com 90gb de espaço ocupado.

O que pode ser esse problema? Já apaguei todos os backups antigos. Pelas pasta que consigo acessar não tem nenhuma pesando mais que 1 ou 2 GB.

Verificou o arquivo de banco de dados?
Usa algum monitoramento de câmera?

Uma vez tive um problema com minha instalação e tive que colocar o HD em outra máquina para pegar os arquivos de backup. Por acaso achei uma pasta “temp” que tinha uns 10gb.
Não lembro o caminho da pasta mas acho que é bom dar uma vasculhada.

Pois é, vi no site do HA aquele serviço recorder.purge, mas não entendi como fazer ele pra limpar a database.

1 Like

Como está gerenciando seus backups? Exclui os antigos?

Só verifica o tamanho.
Ele fica na pasta config.
Se vc não alterou a quantidade de dias ele deve estar com menos de 1gb.

O database está com 277 MB.

Os backups eu deletei todos, menos o último. Ele tá ocupando acho que 700 MB.

Então é outra coisa ocupando espaço.

Com o WinSCP da pra procurar por arquivos grandes.

>20000000

Assim procura arquivos maiores que 20mb por ex

Opa, vou testar quando chegar em casa, obrigado.

Fiz aqui, mas não retornou muitos resultados. Até coloquei um 0 a menos pra procurar algo de uns 2 mb, mas não achou nada que na soma desse 128gb

Vou tentar reinstalar o home assistant do 0 e restaurar o backup

A ordenação está por pasta, coloca por tamanho.

Tem uns arquivos de 260mb, se tiver muitos desses e mais alguns filmes pode explicar o espaço.

Edit

Alguns usuários reportaram algumas pastas consumido grande quantidade de espaço.
Da uma verificada

8G /mnt/data/logs
18G /mnt/data/supervisor/backup (seem to be orphaned backups that don’t show in the UI)
5G /mnt/data/supervisor/addons/data/5c53de3b_esphome/cache 

/mnt/data/supervisor/tmp

Então, eu abri essa pasta /mnt/ e não tem nada ali.
Usei o WinSCP para calcular o tamanho de todas as pastas que abria do diretório (com a exceção do meu HD externo) e deu tipo 2 gb. Será que é algo que não aparece ali?

1 Like

Teoricamente teria que aparecer.

Pode ser problema no hd

Vou economizar e botar um SSD de uns 256 ou 512 GB daí.

Faz um backup e usa algum software para verificar se tem algum erro no HD

No fim acabei metendo um SSD de 480 gb no PC e até agora não saiu do 3% de uso.