Error with media stream contents ao expandir Câmera IP

Boa tarde a todos.
Este é meu primeiro tópico aqui e só criei depois de não ter encontrado nada nas buscas.
Instalei ontem o HA em um rasp Pi3 e finalmente comecei a automação. Eu já tinha uma automação baseado nos aplicativos dos dispositivos mas nunca cheguei a usar o HA a fundo.
Posso dizer que foi uma das melhores escolhas que fiz e hoje tenho praticamente tudo que quero monitorar dentro dele, porém tenho alguns problemas que não consigo solucionar.

Consegui adicionar minha cameça via Generic IP utilizando o endereço RTSP e tenho acesso a ela sem erros, o meu problema foi quando adicionei as cameras da escola da minha filha.
Eles disponibilizam acesso via browser, com autiticação básica de usuario e senha.
O endereço segue o padrão: http://ip:porta/camXX (onde XX são as áreas da escola.

Adicionei normalmente e elas ficaram disponíveis, o meu problema é quando clico pra ver ao vivo, a camera não abre e me retorna o erro: "Error with media stream contents

Fui procurar e vi que em alguns navegadores cameras com codec H.264 tem dificuldades em reprodução ( o que é o caso da minha camera de casa.) Pelos navegadores (Chrome, FF e Edge) o Ao vivo não abre, somente tenho acesso pelo HA no Android.

Mas essas cameras da escola não tenho acesso em lugar algum, apenas vejo as imagens de 10 em 10s.

Alguém teria como me da uma luz do que possa ser?

1 Like

Pessoal, boa tarde.

Consegui ver as cameras ao vivo, tive que usar o Onvier e ir no log de depuração e analisar a URL. Acabei descobrindo que as cameras são MJPEG e ao adicionar via MJPEG IP Camera o video apareceu.

1 Like