Dongle recomenadado

Qual o dongle USB mais recomendado para utilizar no Zigbee2Mqtt?
Estou com um sonoff 3.0 que não estou conseguindo configurar de nenhum jeito no Z2M. Ainda tentei atualizá-lo, tanto pelo método manual, quanto por python, mas não obtive êxito.

Desda já, grato pela atenção de todos!

Primeira coisa é desabilitar o zha.
Ele costuma ativar sozinho quando vc espeta o dongle.

Depois reinicia o z2m e caso não funcione poste os logs

Desabilitar o ZHA nesse caso é só não vincular os dispositivos sugeridos pelo HA, ou precisa fazer algo mais?
Eu coloquei pra ignorar, não sei se é só isso.

Segue os logs:

1 Like

O zha tem que ficar assim ou desabilitado

O que vc postou é a configuração.
Inicia o z2m e depois vai em log

Esse é o erro que está no Log:

Zigbee2MQTT:info 2024-01-19 14:38:57: Starting zigbee-herdsman (0.30.0)
Error: Reset error: Error: {“sequence”:-1} after 10000ms
at /app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/uart.ts:299:23
at Queue.executeNext (/app/node_modules/zigbee-herdsman/src/utils/queue.ts:32:32)

Com essa configuração, vc tentou adicionar o adapter?

Adiciona e se não funcionar posta o log novamente.

Vc fez algum flash no dongle?

Ja tentei colocar adapter e da o mesmo erro. Tammbem nao fiz nenhum flash no dongle.
Tentei colocar a porta nesse formato tambem.
Troquei ate de computador.
To achando que o problema e no dongle.

Tenta configurar o zha, se funcionar o dongle está ok.

Quando vc tentou configurar a porta no outro formato, vc verificou a porta no HA ou usou meu exemplo?

Configurei a porta que achei no hardware do HA.
O ZHA funciona sim!

Vi em alguns foruns que o problema pode ser o modem manager.
Tentei desabilitá-lo via terminal, mas sem exito.

Você conseguiu atualizar?
Eu tive o mesmo problema que você, mas após fazer a atualização. Aí tive que voltar ao firmware original de fábrica e resolveu.

Nao consegui atualizar.
Esta do jeito que veio da loja.

Apaga o arquivo coordinator_backup.json e edita o configuration.yaml igual esta abaixo,
mudando os dados do mqtt e a porta usb, depois inicia o z2m e ve se resolve.

frontend:
  port: 8099
homeassistant: true
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://192.168.86.224:1883'
  user: usr
  password: pwd
serial:
  port: /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0
advanced:
  pan_id: GENERATE
  network_key: GENERATE
  ext_pan_id: GENERATE
  channel: 25

Meus amigos, aleluia deu certo!!!
Creio que quando colocou o código para utilizar o GENERATE solucionou o problema.
Muitíssimo obrigado!!!
Vocês não sabem o quanto isso foi importante para mim que estou iniciando agora no mundo do HA.
Agradeço demais a atenção de todos!

Segue o log final:
[22:30:31] INFO: Preparing to start…
[22:30:31] INFO: Socat not enabled
[22:30:32] INFO: Starting Zigbee2MQTT…
Zigbee2MQTT:info 2024-01-24 22:30:34: Logging to console and directory: ‘/config/zigbee2mqtt/log/2024-01-24.22-30-34’ filename: log.txt
Zigbee2MQTT:info 2024-01-24 22:30:34: Starting Zigbee2MQTT version 1.35.1 (commit #unknown)
Zigbee2MQTT:info 2024-01-24 22:30:34: Starting zigbee-herdsman (0.30.0)
Zigbee2MQTT:info 2024-01-24 22:30:51: zigbee-herdsman started (reset)
Zigbee2MQTT:info 2024-01-24 22:30:51: Coordinator firmware version: ‘{“meta”:{“maintrel”:1,“majorrel”:2,“minorrel”:7,“product”:1,“revision”:20210708,“transportrev”:2},“type”:“zStack3x0”}’
Zigbee2MQTT:info 2024-01-24 22:30:51: Currently 0 devices are joined:
Zigbee2MQTT:info 2024-01-24 22:30:51: Zigbee: disabling joining new devices.
Zigbee2MQTT:info 2024-01-24 22:30:52: Connecting to MQTT server at mqtt://core-mosquitto:1883
Zigbee2MQTT:info 2024-01-24 22:30:52: Connected to MQTT server
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘zigbee2mqtt/bridge/state’, payload ‘{“state”:“online”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: Started frontend on port 8099
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/binary_sensor/1221051039810110150109113116116_0x00124b002c3a2071/connection_state/config’, payload ‘{“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“device_class”:“connectivity”,“entity_category”:“diagnostic”,“name”:“Connection state”,“object_id”:“zigbee2mqtt_bridge_connection_state”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“payload_off”:“offline”,“payload_on”:“online”,“state_topic”:“zigbee2mqtt/bridge/state”,“unique_id”:“bridge_0x00124b002c3a2071_connection_state_zigbee2mqtt”,“value_template”:“{{ value_json.state }}”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/binary_sensor/1221051039810110150109113116116_0x00124b002c3a2071/restart_required/config’, payload ‘{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:“{{ value_json.state }}”}],“availability_mode”:“all”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“device_class”:“problem”,“enabled_by_default”:false,“entity_category”:“diagnostic”,“name”:“Restart required”,“object_id”:“zigbee2mqtt_bridge_restart_required”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“payload_off”:false,“payload_on”:true,“state_topic”:“zigbee2mqtt/bridge/info”,“unique_id”:“bridge_0x00124b002c3a2071_restart_required_zigbee2mqtt”,“value_template”:“{{ value_json.restart_required }}”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/button/1221051039810110150109113116116_0x00124b002c3a2071/restart/config’, payload ‘{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:“{{ value_json.state }}”}],“availability_mode”:“all”,“command_topic”:“zigbee2mqtt/bridge/request/restart”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“device_class”:“restart”,“name”:“Restart”,“object_id”:“zigbee2mqtt_bridge_restart”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“payload_press”:“”,“unique_id”:“bridge_0x00124b002c3a2071_restart_zigbee2mqtt”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/select/1221051039810110150109113116116_0x00124b002c3a2071/log_level/config’, payload ‘{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:“{{ value_json.state }}”}],“availability_mode”:“all”,“command_template”:“{"options": {"advanced": {"log_level": "{{ value }}" } } }”,“command_topic”:“zigbee2mqtt/bridge/request/options”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“entity_category”:“config”,“name”:“Log level”,“object_id”:“zigbee2mqtt_bridge_log_level”,“options”:[“info”,“warn”,“error”,“debug”],“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“state_topic”:“zigbee2mqtt/bridge/info”,“unique_id”:“bridge_0x00124b002c3a2071_log_level_zigbee2mqtt”,“value_template”:“{{ value_json.log_level | lower }}”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/sensor/1221051039810110150109113116116_0x00124b002c3a2071/version/config’, payload ‘{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:“{{ value_json.state }}”}],“availability_mode”:“all”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“entity_category”:“diagnostic”,“icon”:“mdi:zigbee”,“name”:“Version”,“object_id”:“zigbee2mqtt_bridge_version”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“state_topic”:“zigbee2mqtt/bridge/info”,“unique_id”:“bridge_0x00124b002c3a2071_version_zigbee2mqtt”,“value_template”:“{{ value_json.version }}”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/sensor/1221051039810110150109113116116_0x00124b002c3a2071/coordinator_version/config’, payload ‘{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:“{{ value_json.state }}”}],“availability_mode”:“all”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“enabled_by_default”:false,“entity_category”:“diagnostic”,“icon”:“mdi:chip”,“name”:“Coordinator version”,“object_id”:“zigbee2mqtt_bridge_coordinator_version”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“state_topic”:“zigbee2mqtt/bridge/info”,“unique_id”:“bridge_0x00124b002c3a2071_coordinator_version_zigbee2mqtt”,“value_template”:“{{ value_json.coordinator.meta.revision }}”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/sensor/1221051039810110150109113116116_0x00124b002c3a2071/network_map/config’, payload ‘{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:“{{ value_json.state }}”}],“availability_mode”:“all”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“enabled_by_default”:false,“entity_category”:“diagnostic”,“json_attributes_template”:“{{ value_json.data.value | tojson }}”,“json_attributes_topic”:“zigbee2mqtt/bridge/response/networkmap”,“name”:“Network map”,“object_id”:“zigbee2mqtt_bridge_network_map”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“state_topic”:“zigbee2mqtt/bridge/response/networkmap”,“unique_id”:“bridge_0x00124b002c3a2071_network_map_zigbee2mqtt”,“value_template”:"{{ now().strftime(’%Y-%m-%d %H:%M:%S’) }}“}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/sensor/1221051039810110150109113116116_0x00124b002c3a2071/permit_join_timeout/config’, payload '{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:”{{ value_json.state }}“}],“availability_mode”:“all”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“device_class”:“duration”,“entity_category”:“diagnostic”,“name”:“Permit join timeout”,“object_id”:“zigbee2mqtt_bridge_permit_join_timeout”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“state_topic”:“zigbee2mqtt/bridge/info”,“unique_id”:“bridge_0x00124b002c3a2071_permit_join_timeout_zigbee2mqtt”,“unit_of_measurement”:“s”,“value_template”:”{{ iif(value_json.permit_join_timeout is defined, value_json.permit_join_timeout, None) }}“}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘homeassistant/switch/1221051039810110150109113116116_0x00124b002c3a2071/permit_join/config’, payload '{“availability”:[{“topic”:“zigbee2mqtt/bridge/state”,“value_template”:”{{ value_json.state }}“}],“availability_mode”:“all”,“command_topic”:“zigbee2mqtt/bridge/request/permit_join”,“device”:{“hw_version”:“zStack3x0 20210708”,“identifiers”:[“zigbee2mqtt_bridge_0x00124b002c3a2071”],“manufacturer”:“Zigbee2MQTT”,“model”:“Bridge”,“name”:“Zigbee2MQTT Bridge”,“sw_version”:“1.35.1”},“icon”:“mdi:human-greeting-proximity”,“name”:“Permit join”,“object_id”:“zigbee2mqtt_bridge_permit_join”,“origin”:{“name”:“Zigbee2MQTT”,“sw”:“1.35.1”,“url”:“https://www.zigbee2mqtt.io”},“payload_off”:“false”,“payload_on”:“true”,“state_topic”:“zigbee2mqtt/bridge/info”,“unique_id”:“bridge_0x00124b002c3a2071_permit_join_zigbee2mqtt”,“value_template”:”{{ value_json.permit_join | lower }}"}’
Zigbee2MQTT:info 2024-01-24 22:30:52: MQTT publish: topic ‘zigbee2mqtt/bridge/state’, payload ‘{“state”:“online”}’
Zigbee2MQTT:info 2024-01-24 22:30:52: Zigbee2MQTT started!