2 cameras tapo c200 no frigate

Bom dia meninos é meninas.
recentemente eu venho tentando usar o frigate.
eu uso um exemplo que roda bom.

eu gostaria de poder usar 2 cameras tapo.
porem eu não consegui colocar as 2 cameras.

alguém tem um code para ajudar.

esse e o code que uso

mqtt:
host: 192.XXX.X.XXX
port: 1883
topic_prefix: frigate
client_id: frigate
user: USERXXXX
password: PASSXXXX

cameras:
camera_2:
ffmpeg:
inputs:
- path: rtsp://XXXXXXXX:XXXXXXX@192.XXX.X.XXX:554/stream1
roles:
- detect #------------------------ regra para detectar objeto
- clips #------------------------ gravação de clips
- rtmp #------------------------ streaming para visualização no Home Assistant
- record #------------------------ videos gravado
#----------------------------------------------------------------------------------------------
record:
enabled: True
retain:
days: 1
mode: motion
events:
retain:
default: 1
mode: active_objects
detect:
width: 1920
height: 1080
objects:
track:
- person
- cellphone
- cat
snapshots:
enabled: true
timestamp: true
bounding_box: true
retain:
default: 1
objects:
filters:
person:
mask:
- 349,0,362,175,222,165,231,0
- 640,0,640,239,446,146,466,0
motion:
mask:
- 332,0,336,93,234,93,233,0
- 640,0,640,184,465,136,473,0
zones:
entrance:
coordinates: 137,360,218,360,207,30,99,38

ninguém pra me ajudar rsrs?

Qual erro aparece?

Posta o código completo

Usa ```` antes e depois do seu código  

esse code funciona bem o problema e que tenho 2 tapo c200.
e gostaria de add as 2.

  host: 192.xxx.x.xxx
  port: 1883
  topic_prefix: frigate
  client_id: frigate
  user: xxxxxxxxxxxxxxx
  password: maxxxxxxxxxx


cameras:
  camera_2:
    ffmpeg: 
      inputs:
        - path: rtsp://xxxxxxxxx:xxxxxxxxx@192.xxx.x.xxx:554/stream1
          roles:
            - detect #------------------------ regra para detectar objeto
            - clips  #------------------------ gravação de clips
            - rtmp   #------------------------ streaming para visualização no Home Assistant
            - record #------------------------ videos gravado
#----------------------------------------------------------------------------------------------
    record:
      enabled: True
      retain:
        days: 1
        mode: motion
      events:
        retain:
          default: 1
          mode: active_objects
    detect:
      width: 1920
      height: 1080
    objects:
      track:
        - person
        - cellphone
        - cat
    snapshots:
      enabled: true
      timestamp: true
      bounding_box: true
      retain:
        default: 1
    objects:
      filters:
        person:
          mask:
            - 349,0,362,175,222,165,231,0
            - 640,0,640,239,446,146,466,0
    motion:
      mask:
        - 332,0,336,93,234,93,233,0
        - 640,0,640,184,465,136,473,0
    zones:
      entrance:
        coordinates: 137,360,218,360,207,30,99,38  ````

Eu não uso o frigate, mas testa essa configuração:

host: 192.xxx.x.xxx
  port: 1883
  topic_prefix: frigate
  client_id: frigate
  user: xxxxxxxxxxxxxxx
  password: maxxxxxxxxxx


cameras:
  camera_1:
    ffmpeg: 
      inputs:
        - path: rtsp://xxxxxxxxx:xxxxxxxxx@192.xxx.x.xxx:554/stream1
          roles:
            - detect #------------------------ regra para detectar objeto
            - clips  #------------------------ gravação de clips
            - rtmp   #------------------------ streaming para visualização no Home Assistant
            - record #------------------------ videos gravado
#----------------------------------------------------------------------------------------------
    record:
      enabled: True
      retain:
        days: 1
        mode: motion
      events:
        retain:
          default: 1
          mode: active_objects
    detect:
      width: 1920
      height: 1080
    objects:
      track:
        - person
        - cellphone
        - cat
    snapshots:
      enabled: true
      timestamp: true
      bounding_box: true
      retain:
        default: 1
    objects:
      filters:
        person:
          mask:
            - 349,0,362,175,222,165,231,0
            - 640,0,640,239,446,146,466,0
    motion:
      mask:
        - 332,0,336,93,234,93,233,0
        - 640,0,640,184,465,136,473,0
    zones:
      entrance:
        coordinates: 137,360,218,360,207,30,99,38



  camera_2:
    ffmpeg: 
      inputs:
        - path: rtsp://xxxxxxxxx:xxxxxxxxx@192.xxx.x.xxx:554/stream1
          roles:
            - detect #------------------------ regra para detectar objeto
            - clips  #------------------------ gravação de clips
            - rtmp   #------------------------ streaming para visualização no Home Assistant
            - record #------------------------ videos gravado
#----------------------------------------------------------------------------------------------
    record:
      enabled: True
      retain:
        days: 1
        mode: motion
      events:
        retain:
          default: 1
          mode: active_objects
    detect:
      width: 1920
      height: 1080
    objects:
      track:
        - person
        - cellphone
        - cat
    snapshots:
      enabled: true
      timestamp: true
      bounding_box: true
      retain:
        default: 1
    objects:
      filters:
        person:
          mask:
            - 349,0,362,175,222,165,231,0
            - 640,0,640,239,446,146,466,0
    motion:
      mask:
        - 332,0,336,93,234,93,233,0
        - 640,0,640,184,465,136,473,0
    zones:
      entrance:
        coordinates: 137,360,218,360,207,30,99,38

1 Like

Boa tarde Walber.
Muito Obrigada tá funciona bem.
:kissing_heart: :kissing_heart: :kissing_heart:

@magasil

Até amanhã vou subir um tutorial sobre as novidades do frigate que acabaram de sair e tem muita coisa que vai te ajudar, pois pela sua config seu sistema deve estar rodando no “talo” do processador e esquentando bastante.

Para ver o uso do processador, basta seguir esse caminho…
Configurações (Settings) → Dispositivos & Serviços (Devices & Services) → Entidades (Entities)
Procurar por sensor.processor_use e clicar em Info para saber o quanto ele está trabalhando :stuck_out_tongue_winking_eye:

Aqui estou rodando 7 câmeras - e mais um monte de coisas que consomem bastante - e estou entre 65% e 75% de uso.

oque vc acha?

@magasil

Para apenas 2 câmeras, está bem alto, já que estou com 7 e pouco acima disso…

Deixa subir amanhã o tutorial que vai te ajudar a diminuir esse uso ai :stuck_out_tongue:

Boa noite.
muito obrigada.
vou esperar seu tutorial.

@magasil

Ainda não consegui finalizar o tutorial, mas vou te passar o pulo do gato aqui de forma rápida. O que faz o Frigate diminuir o consumo do processador é você separar as streams do vídeo para que ele use uma para detecção (baixa resolução) e outra para gravação (alta resolução). Além disso, repetir os esquemas para cada câmera também aumenta o consumo. Com a atualização, você pode deixar configurado de forma global para todas as câmeras e modificar apenas o que precisar para cada uma especificamente…

Vou te dar um exemplo real…

mqtt:
  host: 0.0.0.0
  port: 1883
  topic_prefix: frigate
  client_id: frigate
  user: user
  password: password

database:
  path: /media/frigate/frigate.db

logger:
  default: info
  logs:
    frigate.event: debug

ffmpeg:
  global_args: -hide_banner -loglevel warning
  hwaccel_args: []
  input_args: -avoid_negative_ts make_zero -fflags +genpts+discardcorrupt -rtsp_transport tcp -timeout 5000000 -use_wallclock_as_timestamps 1
  output_args:
    detect: -f rawvideo -pix_fmt yuv420p
    record: -f segment -segment_time 10 -segment_format mp4 -reset_timestamps 1 -strftime 1 -c copy -an
    rtmp: -c copy -f flv

detect:
  enabled: True
  width: 1280
  height: 720
  fps: 5
  max_disappeared: 25
  stationary:
    interval: 0
    threshold: 50
    max_frames:
      default: 3000
      objects:
        person: 1000
        dog: 1000

objects:
  track:
    - person
    - dog

motion:
  threshold: 25
  contour_area: 30
  delta_alpha: 0.2
  frame_alpha: 0.2
  frame_height: 50
  improve_contrast: True
  mqtt_off_delay: 30

snapshots:
  enabled: False
  clean_copy: True
  timestamp: False
  bounding_box: False
  crop: False
  height: 175
  required_zones: []
  retain:
    default: 10
    objects:
      person: 15
      dog: 15

rtmp:
  enabled: True

live:
  height: 720
  quality: 8

record:
  enabled: False
  expire_interval: 60
  retain:
    days: 0
    mode: all
  events:
    pre_capture: 5
    post_capture: 5
    objects:
      - person
      - dog
    required_zones: []
    retain:
      default: 10
      mode: all
      objects:
        person: 15
        dog: 15

cameras:
  Front_Porch:
    ffmpeg:
      inputs:
        - path: rtsp://login:password@0.0.0.0:554/cam/realmonitor?channel=1&subtype=1
          roles:
            - detect
            - rtmp
        - path: rtsp://login:password@0.0.0.0:554/cam/realmonitor?channel=1&subtype=0
          roles:
            - record
    best_image_timeout: 60
    ui:
      order: 0
      dashboard: True

Note que deixei a opção de RTMP dentro da stream mais baixa (1280x720) pois vejo as câmeras em um tablet e por isso não preciso ver muitos detalhes. Já se for ver em uma TV maior que 40", mude para a stream mais alta (1920x1080) para a imagem não ficar ruim.

Aproveito e já adiciono também um card que vai te ajudar com o Frigate, pois consegue ligar as capturas de foto e vídeo, além da detecção e visualizar o que foi capturado.

type: vertical-stack
cards:
  - camera_view: live
    type: picture-glance
    title: Hall
    entities:
      - entity: camera.front_porch_dog
      - entity: camera.front_porch_person
      - entity: switch.front_porch_detect
      - entity: switch.front_porch_snapshots
      - entity: switch.front_porch_recordings
    camera_image: camera.front_porch
    aspect_ratio: 16x9
  - type: conditional
    conditions:
      - entity: camera.front_porch_dog
        state: 'on'
    card:
      type: picture-entity
      camera_view: auto
      show_state: false
      show_name: false
      entity: camera.front_porch_dog
      tap_action:
        action: none
      hold_action:
        action: none
  - type: conditional
    conditions:
      - entity: camera.front_porch_person
        state: 'on'
    card:
      type: picture-entity
      camera_view: auto
      show_state: false
      show_name: false
      entity: camera.front_porch_person
      tap_action:
        action: none
      hold_action:
        action: none

Forte abraço e Feliz Natal

bom dia.

usei como vc disse.
1- só aparece um camera com o nome Front_Porch.
2 - tenho 2 cameras.

cameras:
  Front_Porch:
    ffmpeg:
      inputs:
        - path: rtsp://xxxxxxxxxxx:xxxxxxxxxxxx@192.xxxxxxxxx:554/stream1
          roles:
            - detect
            - rtmp
        - path: rtsp://xxxxxxxxxxx:xxxxxxxxxxxx@192.xxxxxxxxx:554/stream1
          roles:
            - record
    best_image_timeout: 60

feliz natal também rsrsrs.

@magasil

Mas ai você precisa fazer só essa parte para cada câmera, lembrando de mudar o nome da instância (Front_Porch, no caso, é uma das minhas câmeras, mas você pode usar o nome que quiser nas suas)

Ex:

cameras:
  Hall:
    ffmpeg:
      inputs:
        - path: rtsp://login:password@0.0.0.0:554/cam/realmonitor?channel=1&subtype=1
          roles:
            - detect
            - rtmp
        - path: rtsp://login:password@0.0.0.0:554/cam/realmonitor?channel=1&subtype=0
          roles:
            - record
    best_image_timeout: 60
    ui:
      order: 0
      dashboard: True
  Sala:
    ffmpeg:
      inputs:
        - path: rtsp://login:password@0.0.0.0:554/cam/realmonitor?channel=1&subtype=1
          roles:
            - detect
            - rtmp
        - path: rtsp://login:password@0.0.0.0:554/cam/realmonitor?channel=1&subtype=0
          roles:
            - record
    best_image_timeout: 60
    ui:
      order: 0
      dashboard: True

Pegou agora? :stuck_out_tongue_winking_eye:

Peguei sim Obg tá.
vou fazer te falo :kissing_heart:

Oi britto.
funciona bem. porem não grava video não grava fotos.

@magasil

Boa tarde e feliz ano novo.

Na sua config, mude as parte que coloco em destaque abaixo para que possibilite a gravação e no card você pode ligar manualmente ou criar um rotina para ligar e desligar quando for necessário :wink:

De:

snapshots:
  enabled: False

Para:

snapshots:
  enabled: True

De:

record:
  enabled: False

Para:

record:
  enabled: True

muito obrigada ta.
funciona bem. :kissing_heart: :kissing_heart: :kissing_heart:

Boa noite Britto; estou tentando usar ese card mas tenho muitos erros; por exemplo nao tenho as entidades: camera.xxxxx_person o camera_xxxxxx_dog

Sera que mudou algumas entidades?


obrigado