Ajuda para configurar o SONOFF Zigbee 3.0 USB Dongle Plus

entendo,

uma duvida no HA tenho que ter o Mosquito Broker + Zigbee2mqtt instalado correto?

outra coisa que percebi e que na VM tem esses dois USBs disponiveis e adicionei os dois.

é assim mesmo?

Sim. Os 2.

Tenta um flash novamente o dongle igual vc fez… se não conseguir o defeito é no aparelho… Se funcionar pode ser que na 1a vez o flash não tenha sido 100% correto.

Chegou a confirmar no HA, em qual porta USB ele está detectando a Dongle? Eu uso virtualbox também e está rodando tudo certinho, o problema comigo era que a porta tava errada. Precisa confirmar a porta que está a Dongle e depois alterar no Zigbee2MQTT.

Hoje resolvi o problema “Error while starting zigbee-herdsman”. A solução foi reinstalar o home assistant do zero e voltar os backups. :frowning:

Mas suspeito que o modem manager que cause este problema. Para quem quiser testar faça isto para desinstalar o modem manager.

systemctl disable ModemManager.service
sudo apt-get purge modemmanager

Agora tenho um novo problema com o SONOFF Zigbee e o Zigbee https://www.zigbee2mqtt.io/

Apesar de não dar nenhum erro no log do app, não consigo adicionar nenhum aparelho Zigbee.

Alguém tem alguma dica?

Olá pessoal

Estu penando aqui tb…(estagiário é osso…kkk)

Rodo o HA no Proxmox e meu Dongle Sonoff tb não instala.

image

Verifiquei a porta no MQTT :
image

e no HA:
image

o HA detecta o dongle, mas não finaliza a instalação. :smiling_face_with_tear:

Peguei esse log no HA:

Agradeço se puderem ajudar.

abs Valter

Tenho o mesmo problema com o Sonoff Zigbee 3.0, recebido recentemente. O meu HA é executado em VirtualBox com Mac OS Catalina. Já tentei todas as sugestões acima e outras da internet em geral. Nada funcionou. Também aguardo ajuda.

Bom dia, estou rodando o HA desta mesma forma e está funcionando. Tive problemas no começo era com a porta USB que estava especificada. Primeiro tem que habilitar a porta no VirtualBox para fazer o compartilhamento, depois no HA vai em Configurações > Sistema > Host, vai ter os 3 pontinhos, clica em hardware e verifica em qual porta seu HA está lendo. Depois alterar a porta que está no Zigbee2MQTT (estou rodando com ele).

Grato lizhgois, mas continuo com o problema: “error while starting Zigbee-herdsman” e "error: SRSP - SYS - getExtAddr after 6000ms. Já não sei se é um problema com o hardware (dispositivo usb).

O sonoff Zigbee 3.0 USB Dongle Plus depende muito da qualidade da energia que o alimenta. Especialmente o Raspberry, onde mesmo com um hub USB energizado externamente eu tive problemas de estabilidade com o RP4.

1 Like

O serviço Modem Manager costuma dar problema também.

Para remover:

systemctl stop ModemManager.service
sudo apt-get purge modemmanager

Pode ser que funcione para alguém.

1 Like

Pessoal, só para atualizar. Refiz tudo no meu sistema, desde a reinstalação do Mac OS Catalina, atualização do python, nova instalação do VirtualBox e HA Operating System. Para o Sonoff Zigbee 3.0 USB segui o roteiro dado por Hedda em Add Itead Sonoff CC2652P usb stick bootloader invoke toggle by JelmerT · Pull Request #114 · JelmerT/cc2538-bsl · GitHub. Finalmente, Sonoff USB está instalado, sem mensagens de erros.

1 Like

Após esses dias, e com você efetuando reinícios no sistema, ainda ta funcionando sem nenhum problema?

Sim, após as reinstalações dos dispositivos, o sistema está funcionando. São 7 interruptores zigbee que estão sendo controlados pelo Sonoff Zigbee 3.0, alguns com sinal mais fraco (mais distantes), mas sem perda, por enquanto.

Olá pessoal, estou tentando configurar o Sonoff Zigbee 3.0, fiz a instalação e configuração, mas percebi que o meu só aparece uma opção no USB.

É só essa opção mesmo ou precisa aparecer as duas conforme falado aqui no forum ?

Estou com um problema para atualizar o firmware, segui o vídeo do Patrick, consegui colocar o modo booaloader mais na hora de gravar a nova firmware da esse erro aqui:

1 Like

Se alguém estiver com o mesmo problema que eu para colocar no modo bootloader, segue a dica desse guerreiro aqui, comentário dele esta no vídeo do Patrick, a documentação ensina de forma equivocada como colocar no modo bootloader de forma manual, fiz igual ele disse deu tudo certo.

3 Likes

Utilize um cabo extensor usb para nao ligar o dongle diretamente na usb. Pode ser interferência.

Acredito que possa ser interferência, fonte ou o adaptador SATA. Após ler isso: https://www.usb.org/sites/default/files/327216.pdf eu enrolei papel alumínio no meu SSD. Vamos ver.
Também comprei uma fonte 5V 6A
O próximo passo vai ser trocar o adaptador SATA por um novo.